Peningkatan Layanan Keamanan S/MIME

Peningkatan Layanan Keamanan S/MIME

Andi Hasad
Program Studi Teknik Elektronika
Fakultas Teknik, Universitas Islam 45 (UNISMA)
Jl. Cut Meutia No. 83 Bekasi 17113
Telp. +6221-88344436, Fax. +6221-8801192
Website: andihasad.com, Email: andihasad@yahoo.com

 I. Pendahuluan

Untuk memahami S/MIME, diperlukan pemahaman umum format dasar dari email yang digunakan, yaitu MIME (Multipurpose Internet Mail Extension). MIME merujuk kepada protokol yang luas digunakan di dalam dunia Internet yang memperluas protokol SMTP (Simple Mail Transfer Protocol)yang merupakan protokol dari format standar e-mail tradisional (Request for Comments /  RFC 5322), untuk mengizinkan beberapa data selain teks dengan pengodean ASCII, seperti video, suara, dan berkas biner, agar dapat ditransfer melalui e-mail tanpa harus mentranslasikan terlebih dahulu data-data tersebut ke dalam teks berformat ASCII. MIME merupakan bagian dari protokol HTTP, dan web browser dan server HTTP akan menggunakan MIME untuk menginterpretasikan berkas-berkas e-mail yang dikirimkan dan diterima.

Pada dasarnya, sebuah pesan SMTP hanya boleh mengandung berkas teks saja yang dikodekan dengan menggunakan pengodean ASCII 7-bit saja. Berkas-berkas biner, seperti halnya program, dokumen pengolah kata, dan banyak lagi format lainnya, tidak dapat dikirimkan melalui SMTP. Dengan menggunakan MIME yang didefinisikan di dalam RFC  1521, hal tersebut bukan lagi masalah. Meskipun demikian, protokol ini tidaklah dibuat untuk menggantikan protokol SMTP, tapi hanya memperluas pada dua bagian yaitu : “multipart message body” dan “non-ASCII message content”. MIME menambahkan dua jenis header SMTP tambahan, yakni sebagai berikut:

  • Content-Type: menentukan jenis content yang dibawa oleh pesan-pesan SMTP.
  • Content-Transfer-Encoding: menentukan metode apa yang digunakan untuk mengodekan pesan-pesan SMTP.

RFC 1521 menentukan tujuh buah jenis content dasar yang dapat dimasukkan ke dalam header Content-Type dalam pesan SMTP. Setiap jenis content dasar ini memiliki beberapa Content subtype yang menentukan informasi apa yang dibawa oleh pesan-pesan SMTP, yakni sebagai berikut:

  • Text: yang menentukan bahwa pesan yang dibawa oleh protokol SMTP merupakan teks biasa saja (Text/plain), teks kaya (Text/richtext), Text/html, dan beberapa jenis lainnya.
  • Application: yang menentukan bahwa pesan yang dibawa oleh protokol SMTP merupakan data biner. Beberapa jenis subtype untuk type ini adalah Application/octet-stream, Application/Postscript, Application/msword (dokumen Microsoft Word 97-2003) dan masih banyak lagi.
  • Berkas: yang menentukan bahwa pesan yang dibawa oleh protokol SMTP adalah gambar. Beberapa jenis subtype untuk type ini adalah Image/gif, Image/jpg, Image/png, Image/tiff dan lain-lain.
  • Audio: yang menentukan bahwa pesan yang dibawa oleh protokol SMTP adalah berkas audio.
  • Video: yang menentukan bahwa pesan yang dibawa oleh protokol SMTP adalah berkas video.
  • Message: Beberapa jenis subtype antara lain Message/rfc5322 (pesan asli teks standar RFC 5322), Message/HTTP (untuk lalu lintas HTTP), dan beberapa lainnya
  • Multipart

RFC 1521 juga mendefinisikan metode pengodean data tambahan yang dapat ditentukan pada field Content-Transfer-Encoding dalam header SMTP, yakni:

  • 7 bit: pengodean yang digunakan adalah teks ASCII 7 bit, dengan batasan panjang hingga kurang dari 1000 karakter
  • 8 bit
  • binary
  • quoted-printable
  • base64 (UUEncoded data)
  • x-token

S/MIME (Secure / Multipurpose Internet Mail Extension) adalah peningkatan keamanan standar format email internet MIME, yang didasarkan pada teknologi dari keamanan data RSA. Meskipun Pretty Good Privacy (PGP) dan S/MIME berada pada jalur standar Internet Research Task Force (IETF), kemungkinan S/MIME akan muncul sebagai standar industri untuk penggunaan komersial dan organisasi, sementara PGP akan tetap menjadi pilihan untuk keamanan e-mail pribadi untuk banyak pengguna. S/MIME didefinisikan dalam sejumlah dokumen, yang paling penting adalah RFC3369, 3370, 3850 dan 3851.

II. RFC 822 atau RFC 5322

Sebuah dokumen RFC adalah salah satu dari seri dokumen infomasi dan standar internet bernomor yang diikuti secara luas oleh perangkat lunak untuk digunakan dalam jaringan, internet dan beberapa sistem operasi jaringan, mulai dari Unix, Windows, dan Novell NetWare. RFC kini diterbitkan di bawah arahan Internet Society (ISOC) dan badan-badan penyusun-standar teknisnya, seperti Internet Engineering Task Force (IETF) atau Internet Research Task Force (IRTF). Semua standar Internet dan juga TCP/IP selalu dipublikasikan dalam RFC, meskipun tidak semua RFC mendefinisikan standar Internet. Beberapa RFC bahkan hanya menawarkan informasi, percobaan/eksperimen, atau hanya informasi sejarah saja. Sebelum menjadi sebuah dokumen RFC, sebuah dokumen yang diajukan akan dianggap menjadi draf Internet (Internet draft), yang merupakan sebuah dokumen yang umumnya dikembangkan oleh satu orang pengembang di dalam kelompok kerja IETF atau IRTF. Sebagai contoh, kelompok kerja IPv6 (IPv6 working group) mengkhususkan usahanya hanya untuk mengembangkan standar-standar yang akan digunakan pada IPv6, protokol calon pengganti IPv4. Setelah beberapa waktu, dokumen tersebut akan diulas dan akhirnya harus diterima secara konsensus oleh para penguji. Dan setelah diterima, maka IETF pun menerbitkan versi final dari draf Internet tersebut menjadi sebuah RFC dan kemudian memberikan nomor urut kepadanya, yang disebut sebagai RFC Number.

RFC 5322 mendefinisikan format untuk pesan teks yang dikirim menggunakan mail (surat) elektronik. RFC 5322 telah menjadi standar untuk pesan teks berbasis internet mail dan masih umum digunakan. Dalam konteks RFC 5322, pesan akan dipandang sebagai amplop dan isinya (Gambar 1). Amplop berisi informasi apa pun yang diperlukan untuk mencapai transmisi dan pengiriman sedangkan isi membentuk objek yang akan dikirim ke penerima.

Standar RFC 5322 hanya berlaku untuk isi. Namun, standar isi mencakup satu set field header yang dapat digunakan oleh sistem mail untuk membuat amplop, dan standar ini dimaksudkan untuk memudahkan perolehan informasi oleh program. Struktur keseluruhan dari sebuah pesan yang sesuai dengan RFC5322 sangat sederhana.

Gambar 1 Ilustrasi pesan dalam konteks RFC 5322

Sebuah pesan terdiri dari beberapa jumlah baris header (the header) diikuti oleh teks yang tidak dibatasi penggunaannya (the body). Header dipisahkan dari body oleh baris kosong.

Sebuah header biasanya terdiri dari sebuah kata kunci, diikuti oleh titik dua, diikuti oleh argumen kata kunci; format memungkinkan sebuah garis panjang untuk dipecah menjadi beberapa baris. Kata kunciyang paling sering digunakan adalah Dari, Untuk, Subjek, danTanggal. Berikut adalah contoh pesan

Date: October 8, 2009 2:15:49 PM EDT
From: William Stallings <ws@shore.net>
Subject: The Syntax in RFC 5322
To: Smith@Other-host.com
Cc: Jones@Yet-Another-Host.com

Hello. This section begins the actual
message body, which is delimited from the
message heading by a blank line.

Bidang lain yang umum ditemukan dalam header RFC 5322 adalah Message-ID. Bidang ini berisi pengenal unik terkait dengan pesan ini.

III. Keterbatasan RFC 5322

MIME adalah perluasan untuk kerangka RFC 5322 yang dimaksudkan untuk mengatasi beberapa masalah dan keterbatasan penggunaan SMTP (Simple Mail Transfer Protocol) atau protokol transfer mail lain dan RFC 5322 untuk mail elektronik. Daftar keterbatasan antara lain :

  1. SMTP tidak bisa mengirimkan file executable atau objek biner lainnya. Sejumlah skema sedang digunakan untuk mengkonversi file biner ke dalam bentuk teks yang dapat digunakan oleh sistem mail SMTP, termasuk UNIX populer uuencode / skema uudecode. Namun, tidak satupun dari hal iniyang merupakan suatu standar atau bahkan standar de facto.
  2. SMTP tidak dapat mengirimkan data teks yang berisi karakter bahasa nasional karena ini diwakili oleh kode 8-bit dengan nilai desimal 128 atau lebih tinggi, dan SMTP terbatas untuk ASCII 7-bit.
  3. ServerSMTP mungkin menolak pesan email lebih dari ukuran tertentu.
  4. GatewaySMTP yang menerjemahkan antara ASCII dan karakter kode EBCDIC tidak menggunakan satu set konsisten pemetaan yang berakibat pada masalah terjemahan.
  5. GatewaySMTP ke jaringan mail elektronik X.400 tidak dapat menangani data nontextual termasuk dalam pesan X.400.
  6. Beberapa implementasi SMTP tidak mematuhi sepenuhnya standar SMTP yang  didefinisikan dalam RFC 821. Masalah umum meliputi:
  • Penghapusan, penambahan, atau pemesanan ulang dari carriage return dan linefeed
  • Memotong atau pembungkus garis lebih panjang dari 76 karakter
  • Penghapusan trailing white space (tab dan karakter spasi)
  • Padding baris dalam pesan dengan panjang yang sama
  • Konversi karakter tab ke beberapa karakter spasi

MIME dimaksudkan untuk menyelesaikan masalah-masalah ini dengan cara yang kompatibel dengan implementasi RFC 5322. Spesifikasi disediakan dalam RFC 2045 sampai 2049.

IV. MIME

Spesifikasi MIME mencakup unsur-unsur berikut :

  1. Lima bidang header pesan baru didefinisikan, yang dapat dimasukkan dalam RFC 5322 header. Bidang ini memberikan informasi tentang body pesan.
  2. Sejumlah format konten yang didefinisikan, sehingga standardisasi representasi multimedia yang mendukung mail elektronik.
  3. Transfer encoding didefinisikan yang memungkinkan konversi format konten ke dalam bentuk yang dilindungi dari perubahan oleh sistem email.

Dalam subbagian ini, diperkenalkan bidang-bidang pesan lima header. Kesepakatan   dua  subbagian berikutnya dengan format isi dan pengodean transfer. Bidang the fiveheader didefinisi kan  dalam MIME, sebagai berikut :

  • MIME-Version: Harus memiliki nilai parameter 1.0. Bidang ini menunjukkan bahwa pesan tersebut sesuai dengan RFC 2045 dan 2046.
  • Content-Type: Menjelaskan data yang terdapat dalam body dengan rincian yang memadai bahwa agen user penerima dapat mengambil seorang agen yang tepat atau mekanisme untuk mewakili data kepada user atau berurusan dengan data dalam cara yang tepat.
  • Content-Transfer-Encoding: Menunjukkan tipe transformasi yang telah digunakan untuk mewakili body pesan dengan cara yang dapat diterima untuk transportasi mail.
  • Content-ID: Digunakan untuk mengidentifikasi MIME entitas unik dalam beberapa konteks.
  • Content-Description: deskripsi teks dari objek dengan body, ini berguna ketika objek tidak dapat dibaca (misalnya, data audio).

Salah satu atau semua bidang ini mungkin muncul dalam sebuah header normal RFC 5322. Implementasi yang sesuai harus mendukung MIME-Version, Content-Type, dan Content-Transfer-Encoding bidang, sedangkan Content-ID dan bidang Content-Deskripsi adalah opsional dan dapat diabaikan oleh implementasi penerima.

V. S/MIME

S/MIME memanfaatkan sejumlah tipe konten baru MIME yang ditunjukkan dalam Tabel 1. Semua tipe aplikasi baru menggunakan penandaan PKCS mengacu pada spesifikasi kriptografi kunci publik yang dikeluarkan oleh RSA Laboratories.

Tabel 1. Tipe-tipe konten S/MIME

VI. Peningkatan Layanan Keamanan S-MIME

S/MIME melindungi entitas MIME dengan tanda tangan, enkripsi, atau keduanya. Entitas MIME merupakan pesan keseluruhan (kecuali untuk header RFC 5322), jika tipe konten MIME multipart, maka entitas MIME terdiri dari satu atau lebih dari subbagian pesan entitas MIME yang disusun menurut aturan normal untuk persiapan pesan MIME. Entitas MIME kemudian ditambah beberapa data yang berhubungan dengan keamanan, seperti algoritma identifikasi dan sertifikat yang diproses oleh S/MIME untuk menghasilkan apa yang dikenal sebagai objek PKCS. Sebuah objek PKCS kemudian diperlakukan sebagai konten pesan dan dibungkus di dalam MIME (disediakan dengan header MIME yang sesuai). Penerapan algoritma keamanan menggunakan transfer encoding base64.

Beberapa jasa peningkatan layanan keamanan yang dapat dilakukan, yaitu :

  • Signed receipt : Sebuah tanda terima yang telah ditandatangani dapat diminta dalam objek SignedData. Mengembalikan tanda terima yang telah ditandatangani menyediakan bukti pengiriman pesan dan memungkinkan pengirim untuk menunjukkan kepada pihak ketiga bahwa penerima telah menerima pesan. Tanda tangan penerima pesan seluruhnya asli ditambah tanda tangan pengirim pesan asli dan menambahkan tanda tangan baru untuk membentuk pesan  baru S/MIME.
  • Security labels : Label keamanan dapat dimasukkan dalam atribut otentikasi objek SignedData.
  • Penggunaan MLA S/MIME untuk membebaskan pengguna mengirim pesan ke beberapa penerima yang memerlukan pemrosesan tertentu per-penerima. MLA dapat mengambil satu pesan yang merupakan seperangkat keamanan informasi tentang sensitivitas dari konten yang dilindungi oleh enkapsulasi S/MIME. Label dapat digunakan untuk kontrol akses, dengan menunjukkan pengguna yang  diizinkan akses ke objek. Kegunaan lain mencakup prioritas (kerahasiaan, konfidensial, dibatasi, dan sebagainya) atau berbasis peran, yang menggambarkan jenis orang dapat melihat informasi (misalnya, tim pasien kesehatan, agen penagihan medis, dll).
  • Secure mailing lists : Pemanfaatan Mail List Agent yang masuk, melakukan enkripsi penerima-spesifik untuk masing-masing penerima, dan forward pesan, pengirim pesan hanya perlu mengirim pesan ke MLA dengan enkripsi yang dilakukan dengan menggunakan kunci publik MLA tersebut.

Selengkapnya … download [pdf]

Referensi :

Neyman Shelvie N., Materi Kuliah Keamanan Informasi, Sekolah Pascasarjana IPB, Bogor

Stalling William, 2005, Cryptography and Network Security, Principles and Practices, Prentice Hall, USA

Stalling William, 2011,Network Security Essential, Applications and Standards, Prentice Hall, USA

Operasi dan Aplikasi TRIAC

OPERASI DAN APLIKASI TRIAC

 Andi Hasad
Program Studi Teknik Elektronika
Fakultas Teknik, Universitas Islam 45 (UNISMA)
Jl. Cut Meutia No. 83 Bekasi 17113
Telp. +6221-88344436, Fax. +6221-8801192
Website: andihasad.com, Email: andihasad@yahoo.com

Triac atau dikenal dengan nama Bidirectional Triode Thyristor, dapat mengalirkan arus listrik ke kedua arah ketika ditrigger (dihidupkan). Triac dapat ditrigger dengan memberikan tegangan positif ataupun negatif pada elektroda gerbang. Sekali ditrigger, komponen ini akan terus menghantar hingga arus yang mengalir lebih rendah dari arus genggamnya, misalnya pada akhir paruh siklus dari arus bolak-balik. Operasi triac sangat mirip dengan SCR. Perbedaannya adalah apabila SCR dihubungkan ke dalam rangkaian ac, tegangan output disearahkan menjadi arus searah sedangkan triac dirancang untuk menghantarkan pada kedua tengahan dari bentuk gelombang output. Oleh karena itu, output dari triac adalah arus bolak-balik, bukan arus searah. Triac dibuat untuk menyediakan cara agar kontrol daya ac ditingkatkan.

Gambar 1 Bentuk fisik triac

Operasi Triac

Kontruksi triac diperlihatkan pada Gambar 2. Triac beroperasi sebagai dua SCR dalam satu bungkus dan dipasang paralel berkebalikan. Rangkaian ekivalen triac diperlihatkan sebagai dua SCR yang dihubungkan paralel terbalik seperti diperlihatkan pada Gambar 3. Dengan demikian, triac mampu menghantarkan dengan salah satu polaritas tegangan terminal. Triac dapat juga ditrigger dengan salah satu polaritas sinyal gerbang.

Gambar 2 Konstruksi Triac

Gambar 3 Struktur, simbol dan rangkaian ekivalen triac

Triac mempunyai tiga terminal; dua terminal utama (MT2) dan terminal utama 1 (MT1) dan gerbang (G). Terminal MT2 dan MT1 dirancang demikian sebab aliran arus adalah dua arah. Karena aliran berinteraksi dengan gerbang, MT1 digunakan sebagai pengukuran terminal referen. Arus dapat mengalir antara MT2 dan MT1 dan juga antara gerbang dan MT1. Triac dapat ditrigger agar konduksi pada salah satu arah dengan arus gerbang bergerak masuk atau keluar dari gerbang. Apabila aliran arah arus terminal utama ditentukan, triac pada dasarnya mempunyai karakteristik pengoperasian internal yang sama dengan SCR. Triac mempunyai empat kemungkinan mode pentriggeran. Sehubungan dengan MT1 yaitu:

  • MT2 adalah positif dan gerbang positif
  • MT2 adalah positif dan gerbang negatif
  • MT2 adalah negatif dan gerbang positif
  • MT2 adalah negatif dan gerbang negatif

Gambar 4 Mode pentriggeran triac

Dua mode pentriggeran tersebut digambarkan pada Gambar 4. Karena triac dapat menghantarkan pada kedua tengahan siklus, maka sangat bermanfaat untuk mengontrol beban yang beroperasi pada arus searah. Efisiensi penuh dapat dicapai dengan menggunakan kedua tengahan gelombang dari tegangan input ac.

Aplikasi Triac

Skema rangkaian penghubungan triac yang dioperasikan dari sumber ac diperlihatkan pada Gambar 5.

 Gambar 5 Rangkaian penghubungan triac ac

Jika tombol tekan PB1 dipertahankan tertutup, arus trigger terus-menerus diberikan pada gerbang. Triac menghantarkan pada kedua arah untuk menghubungkan semua tegangan ac yang diberikan pada beban. Jika tombol tekan dibuka, triac kembali OFF atau mati, apabila tegangan sumber ac dan penahanan arus turun menjadi nol atau polaritas terbalik. Perhatikan bahwa tidak seperti output dari rangkaian SCR yang sama, output rangkaian ini adalah arus bolak-balik, bukan arus searah.

 Gambar 6 Aplikasi triac pada rangkaian penghubungan arus pada motor

Satu aplikasi umum dari triac adalah penghubungan arus ac pada motor ac. Rangkaian penghubungan motor triac pada Gambar 6 menggambarkan kemampuan triac untuk mengontrol jumlah arus beban yang besar dengan jum­lah arus gerbang yang kecil. Aplikasi ini akan bekerja seperti relay solid-state. Transformator penurun tegangan 24 V digunakan untuk mengurangi tegangan pada rangkaian thermostat. Tahanan membatasi jumlah aliran arus pada rang­kaian gerbang-MTl ketika thermostat terhubung kontaknya untuk menswitch triac dan motor ON. Ukuran kerja arus maksimum dari kontak thermostat jauh lebih rendah dibandingkan dengan arus kerja triac dan motor. Jika thermostat yang sama dihubungkan seri dengan motor untuk mengoperasikan motor secara langsung, kontak akan dihancurkan dengan aliran arus yang lebih besar.

Gambar 7 Aplikasi triac untuk merubah arus

Triac dapat digunakan untuk merubah arus ac rata-rata menjadi beban ac seperti terlihat pada Gambar 8. Rangkaian trigger mengontrol titik dari bentuk gelombang ac di mana triac yang dihubungkan ON. Bentuk gelombang yang terjadi adalah masih arus bolak-balik, tapi arus rata-rata diubah. Pada rangkaian penerangan, perubahan arus menjadi lampu pijar akan merubah jumlah cahaya yang dipancarkan oleh lampu. Jadi, triac dapat digunakan sebagai pengontrol keredupan cahaya. Pada rangkaian motor yang sama, perubahan arus itu akan merubah kecepatan motor. Diac adalah alat seperti transistor dua terminal yang digunakan untuk mengontrol trigger SCR dan triac.

Tidak seperti transistor, dua sambungan diac diberi bahan campuran yang sama kuat dan sama. Simbol diac memperlihatkan bahwa diac bertindak seperti dua dioda yang menunjuk pada arah yang berbeda. Arus mengalir melalui diac (pada salah satu arah) ketika tegangan antaranya mencapai tegangan breakover yang diratakan. Pulsa arus yang dihasilkan ketika diac berubah dari status non-induksi ke status konduksi digunakan untuk pentriggeran gerbang SCR dan triac.

Gambar 8 Aplikasi diac/triac sebagai peredup lampu

Rangkaian eksperimental peredup lampu triac/diac diperlihatkan pada Gambar 8. Ketika tahanan variabel R, ada pada harga terendahnya (terang), kapasitor C1 mengisi dengan cepat pada permulaan dari masing-masing setengah siklus dari tegangan ac. Jika tegangan antara C1, mencapai tegangan triac over dari diac, C1 dikosongkan pada gerbang triac. Jadi, triac ON (lebih awal) pada tiap setengah siklus dan bertahan hidup (ON) sampai akhir triac setengah siklus. Oleh karena itu. arus akan mengalir lewat lampu untuk sebagian besar dari diac setengah siklus dan menghasilkan kecerahan (terang) yang penuh. Pada saat tahanan R1 naik, waktu yang diperlukan untuk mengisi C1, sampai tegangan breakover dari diac bertambah. Hal ini menyebabkan triac menyala kemudian pada setiap setengah siklus. Sehingga panjang waktu arus mengalir pada lampu menjadi berkurang dan cahaya yang dipancarkan juga berkurang.

Selengkapnya … Download [pdf]

Referensi

Hasad A. 2011. Materi Kuliah Elektronika Industri, Teknik Elektro, UNISMA Bekasi

Petruzella F.D., 2001. Elektronik Industri, Andi Yogyakarta

Operasi dan aplikasi SCR

OPERASI DAN APLIKASI SCR

Andi Hasad
Program Studi Teknik Elektronika
Fakultas Teknik, Universitas Islam 45 (UNISMA)
Jl. Cut Meutia No. 83 Bekasi 17113
Telp. +6221-88344436, Fax. +6221-8801192
Website: andihasad.com, Email: andihasad@yahoo.com

Silicon Controlled Rectifier (SCR) merupakan alat semikonduktor empat lapis (PNPN) yang menggunakan tiga kaki yaitu anoda (anode), katoda (cathode), dan gerbang (gate) – dalam operasinya. SCR adalah salah satu thyristor yang paling sering digunakan dan dapat melakukan penyaklaran untuk arus yang besar.

Gambar 1 Bentuk fisik SCR

SCR dapat dikategorikan menurut jumlah arus yang dapat beroperasi, yaitu SCR arus rendah dan SCR arus tinggi. SCR arus rendah dapat bekerja dengan arus anoda kurang dari 1 A sedangkan SCR arus tinggi dapat menangani arus beban sampai ribuan ampere.

Gambar 2 Konstruksi dan simbol SCR

Simbol skematis untuk SCR mirip dengan simbol penyearah dioda dan diperlihatkan pada Gambar 2. Pada kenyataannya, SCR mirip dengan dioda karena SCR menghantarkan hanya pada satu arah. SCR harus diberi bias maju dari anoda ke katoda untuk konduksi arus. Tidak seperti pada dioda, ujung gerbang yang digunakan berfungsi untuk menghidupkan alat.

Operasi SCR
Operasi SCR sama dengan operasi dioda standar kecuali bahwa SCR memerlukan tegangan positif pada gerbang untuk menghidupkan saklar. Gerbang SCR dihubungkan dengan basis transistor internal, dan untuk itu diperlukan setidaknya 0,7 V untuk memicu SCR. Tegangan ini disebut sebagai tegangan pemicu gerbang (gate trigger voltage). Biasanya pabrik pembuat SCR memberikan data arus masukan minimum yang dibutuhkan untuk menghidupkan SCR. Lembar data menyebutkan arus ini sebagai arus pemicu gerbang (gate trigger current). Sebagai contoh lembar data 2N4441 memberikan tegangan dan arus pemicu :
VGT = 0,75 V
IGT = 10 mA
Hal ini berarti sumber yang menggerakkan gerbang 2N4441 harus mencatu 10 mA pada tegangan 0,75 V untuk mengunci SCR.

Gambar 3 SCR yang dioperasikan dari sumber DC

Skema rangkaian penghubungan SCR yang dioperasikan dari sumber DC diperlihatkan pada Gambar 3. Anoda terhubung sehingga positif terhadap katoda (bias maju). Penutupan sebentar tombol tekan (push button) PB1 memberikan pengaruh positif tegangan terbatas pada gerbang SCR, yang men-switch ON rangkaian anoda-katoda, atau pada konduksi, kemudian menghidupkan lampu.Rangkaian anoda-katoda akan terhubung ON hanya satu arah. Hal ini terjadi hanya apabila anoda positif terhadap katoda dan tegangan positif diberikan kepada gerbang Ketika SCR ON, SCR akan tetap ON, bahkan sesudah tegangan gerbang dilepas. Satu-satunya cara mematikan SCR adalah penekanan tombol tekan PB2 sebentar, yang akan mengurangi arus anoda-katoda sampai nol atau dengan melepaskan tegangan sumber dari rangkaian anoda-katoda.

SCR dapat digunakan untuk penghubungan arus pada beban yang dihubungkan pada sumber AC. Karena SCR adalah penyearah, maka hanya dapat menghantarkan setengah dari gelombang input AC. Oleh karena itu, output maksimum yang diberikan adalah 50%; bentuknya adalah bentuk gelombang DC yang berdenyut setengah gelombang.

Gambar 4 SCR yang dioperasikan dari sumber AC

Skema penghubungan rangkaian SCR yang dioperasikan dari sumber AC diperlihatkan oleh Gambar 4. Rangkaian anoda-katoda hanya dapat di switch ON selama setengah siklus dan jika anoda adalah positif (diberi bias maju). Dengan tombol tekan PB1 terbuka, arus gerbang tidak mengalir sehingga rangkaian anoda-katoda bertahan OFF. Dengan menekan tombol tekan PB1 dan terus-menerus tertutup, menyebabkan rangkaian gerbang-katoda dan anoda-katoda diberi bias maju pada waktu yang sama. Prosedur arus searah berdenyut setengah gelombang melewati depan lampu. Ketika tombol tekan PB1 dilepaskan, arus anoda-katoda secara otomatis menutup OFF ketika tegangan AC turun ke nol pada gelombang sinus.

Gambar 5 Aplikasi SCR sebagai kontrol output suplai daya pada motor DC

Ketika SCR dihubungkan pada sumber tegangan AC, SCR dapat juga digunakan untuk merubah atau mengatur jumlah daya yang diberikan pada beban. Pada dasarnya SCR melakukan fungsi yang sama seperti rheostat, tetapi SCR jauh lebih efisien. Gambar 5 menggambarkan penggunaan SCR untuk mengatur dan menyearahkan suplai daya pada motor DC dari sumber AC.

Gambar 6 Aplikasi SCR untuk start lunak motor AC induksi 3 fase

Rangkaian SCR dari Gambar 6 dapat digunakan untuk “start lunak” dari motor induksi 3 fase. Dua SCR dihubungkan secara terbalik paralel untuk memperoleh kontrol gelombang penuh. Dalam tema hubungan ini, SCR pertama mengontrol tegangan apabila tegangan positif dengan bentuk gelombang sinus dan SCR yang lain mengontrol tegangan apabila tegangan negatif. Kontrol arus dan percepatan dicapai dengan pemberian trigger dan penyelaan SCR pada waktu yang berbeda selama setengah siklus. Jika pulsa gerbang diberikan awal pada setengah siklus, maka outputnya tinggi. Jika pulsa gerbang diberikan terlambat pada setengah siklus, hanya sebagian kecil dari bentuk gelombang dilewatkan dan mengakibatkan outputnya rendah.

Aplikasi SCR
Pada aplikasinya, SCR tepat digunakan sebagai saklar solid-state, namun tidak dapat memperkuat sinyal seperti halnya transistor. SCR juga banyak digunakan untuk mengatur dan menyearahkan suplai daya pada motor DC dari sumber AC, pemanas, AC, melindungi beban yang mahal (diproteksi) terhadap kelebihan tegangan yang berasal dari catu daya, digunakan untuk “start lunak” dari motor induksi 3 fase dan pemanas induksi. Sebagian besar SCR mempunyai perlengkapan untuk penyerapan berbagai jenis panas untuk mendisipasi panas internal dalam pengoperasiannya.

Selengkapnya… download [pdf]

Referensi
Hasad A. 2011. Materi Kuliah Elektronika Industri, Teknik Elektro, UNISMA Bekasi
Malvino A.P., 2003. Prinsip-prinsip Elektronika, Salemba Teknika, Jakarta
Petruzella F.D., 2001. Elektronik Industri, Andi Yogyakarta

Album Photo Robotika KRI-KRCI 2010

Slideshow ini membutuhkan JavaScript.

Thyristor dan Aplikasinya

THYRISTOR DAN APLIKASINYA

Andi Hasad
Program Studi Teknik Elektronika
Fakultas Teknik, Universitas Islam 45 (UNISMA)
Jl. Cut Meutia No. 83 Bekasi 17113
Telp. +6221-88344436, Fax. +6221-8801192
Website: andihasad.com, Email: andihasad@yahoo.com

Thyristor berasal dari bahasa Yunani yang berarti ‘pintu’. Sifat dan cara kerja komponen ini memang mirip dengan pintu yang dapat dibuka dan ditutup untuk melewatkan arus listrik. Thyristor merupakan salah satu tipe devais semikonduktor daya yang paling penting dan telah banyak digunakan secara ekstensif pada rangkaian daya . Thyristor biasanya digunakan sebagai saklar/bistabil, beroperasi antara keadaan non konduksi ke konduksi. Pada banyak aplikasi, thyristor dapat diasumsikan sebagai saklar ideal akan tetapi dalam prakteknya thyristor memiliki batasan karakteristik tertentu. Beberapa komponen yang termasuk thyristor antara lain PUT (Programmable Uni-junction Transistor), UJT (Uni-Junction Transistor ), GTO (Gate Turn Off Thyristor),  SCR (Silicon Controlled Rectifier), LASCR (Light Activated Silicon Controlled Rectifier), RCT (Reverse Conduction Thyristor), SITH (Static Induction Thyristor), MOS-Controlled Thyristor (MCT).

Gambar 1 Thyristor

Struktur Thyristor

Ciri  dari sebuah thyristor adalah komponen yang terbuat dari bahan semiconductor silicon. Walaupun bahannya sama, tetapi struktur P-N junction yang dimilikinya lebih kompleks dibanding transistor bipolar atau MOS. Komponen thyristor lebih digunakan sebagai saklar (switch) daripada sebagai penguat arus atau tegangan seperti halnya transistor.

Gambar 2  Struktur Thyristor

Struktur dasar thyristor adalah struktur 4 layer PNPN seperti yang ditunjukkan pada Gambar 2. Sebuah thyristor dapat bekerja dan dapat disimulasikan terdiri dari sebuah resistor R on, Sebuah induktor Lon, sebuah sumber tegangan DC V yang terhubung seri dengan Switch (SW). SW dikontrol oleh signal Logic yang yang bergantung pada tegangan Vak, arus Iak  dan signal Gate (G). Simulasi ini dapat dilihat pada Gambar 3.

Gambar 3  Simulasi Operasi Thyristor

Jika dipilah, struktur ini dapat dilihat sebagai dua buah struktur junction PNP dan NPN yang tersambung di tengah. Ini tidak lain adalah dua buah transistor PNP dan NPN yang tersambung pada masing-masing kolektor dan base. Jika divisualisasikan sebagai transistor Q1 dan Q2, maka struktur thyristor ini dapat diperlihatkan seperti pada Gambar 4  berikut ini.

 Gambar 4  Visualisasi dengan  transistor

Kolektor transistor Q1 tersambung pada base transistor Q2 dan sebaliknya kolektor transistor Q2 tersambung pada base transistor Q1.  Rangkaian transistor yang demikian menunjukkan adanya loop penguatan arus di bagian tengah. Dimana diketahui bahwa Ic = BIb, yaitu arus kolektor adalah penguatan dari arus base.  Jika misalnya ada arus sebesar Ib yang mengalir pada base transistor Q2, maka akan ada arus Ic yang mengalir pada kolektor Q2. Arus kolektor ini merupakan arus base Ib pada transistor Q1, sehingga akan muncul penguatan pada pada arus kolektor transistor Q1. Arus kolektor transistor Q1 tdak lain adalah arus base bagi transistor Q2. Demikian seterusnya sehingga makin lama sambungan PN dari thyristor ini di bagian tengah akan mengecil dan hilang. Tertinggal hanyalah lapisan P dan N di bagian luar.

Jika keadaan ini tercapai, maka struktur yang demikian todak lain adalah struktur dioda PN (anoda-katoda) yang sudah dikenal. Pada saat yang demikian, disebut bahwa thyristor dalam keadaan ON dan dapat mengalirkan arus dari anoda menuju katoda seperti layaknya sebuah dioda.

Karakteristik Thyristor

Karakteristik Thyristor dapat dilihat pada Gambar 4. Karaktristik tegangan versus arus ini diperlihatkan bahwa thyristor mempunyai 3 keadaan atau daerah, yaitu :

  1. Keadaan pada saat tegangan balik (daerah I)
  2. Keadaan pada saat tegangan maju (daerah II)
  3. Keadaan pada saat thyristor konduksi (daerah III)

 

Gambar 5  Karakterisitik Thyristor

Pada daerah I, thyristor sama seperti diode, dimana pada keadaan ini tidak ada arus yang mengalir sampai dicapainya batas tegangan tembus (Vr). Pada daerah II terlihat bahwa arus tetap tidak akan mengalir sampai dicapainya batas tegangan penyalaan (Vbo). Apabila tegangan mencapai tegangan penyalaan, maka tiba – tiba tegangan akan jatuh menjadi kecil dan ada arus mengalir. Pada saat ini thyristor mulai konduksi dan ini adalah merupakan daerah III. Arus yang terjadi pada saat thyristor konduksi, dapat disebut sebagai arus genggam (IH = Holding Current). Arus IH ini cukup kecil yaitu dalam orde miliampere.  Untuk membuat thyristor kembali off, dapat dilakukan dengan menurunkan arus thyristor tersebut dibawah arus genggamnya (IH) dan selanjutnya diberikan tegangan penyalaan.

Secara umum, aplikasi Thyristor adalah  :

• Mengontrol kecepatan dan frekuensi
• Penyearahan
• Pengubahan daya
• Manipulasi robot
• Kontrol temperatur
• Kontrol cahaya

Selengkapnya … Download [pdf]

Referensi :

Hasad A. 2011. Materi Kuliah Elektronika Industri, Teknik Elektro, UNISMA, Bekasi.

Petruzella F.D., 2001, Elektronik Industri, Andi Yogyakarta

Rashid M.H., 1999, Elektronika Daya, PT. Prenhallindo, Jakarta

Principal Component Analysis (PCA)

PRINCIPAL COMPONENT ANALYSIS (PCA)

A. Hasad
Program Studi Teknik Elektronika
Fakultas Teknik, Universitas Islam 45 (UNISMA)
Jl. Cut Meutia No. 83 Bekasi 17113
Telp. +6221-88344436, Fax. +6221-8801192
Website: andihasad.com, Email: andihasad@yahoo.com

Dalam statistika, analisis komponen utama (principal component analysis / PCA) adalah teknik yang digunakan untuk menyederhanakan suatu data, dengan cara mentransformasi linier sehingga terbentuk sistem koordinat baru dengan varians maksimum. PCA dapat digunakan untuk mereduksi dimensi suatu data tanpa mengurangi karakteristik data tersebut secara signifikan.

Analisis komponen utama  merupakan suatu teknik statistik untuk mengubah dari sebagian besar  variabel asli yang digunakan yang saling berkorelasi satu dengan yang lainnya menjadi satu set variabel baru yang lebih kecil dan saling bebas (tidak berkorelasi lagi). Jadi analisis komponen utama berguna untuk mereduksi data, sehingga lebih mudah untuk menginterpretasikan data-data tersebut (Johnson & Wichern, 1982). Analisis ini merupakan analisis antara dari suatu proses penelitian yang besar atau suatu awalan dari analisis berikutnya, bukan merupakan suatu analisis yang langsung berakhir. Misalnya komponen utama bisa merupakan masukan untuk regresi berganda atau analisis faktor.

Dilihat secara aljabar linier, komponen utama adalah kombinasi linier-kombinasi linier tertentu dari p peubah acak x1,x2,x3,….,xm. Secara geometris kombinasi linier ini merupakan sistem koordinat baru yang didapat dari rotasi sistem semula dengan x1,x2,….,xm sebagai sumbu koordinat. Sumbu baru tersebut merupakan arah dengan variabilitas maksimum dan memberikan kovariansi yang lebih sederhana. Sumber lain merumuskan bahwa PCA merupakan teknik linier untuk memproyeksikan data vektor yang berdimesi tinggi ke vektor yang mempunyai dimensi lebih rendah (Turk, 1991). PCA lebih banyak digunakan untuk keperluan ekstraksi fitur citra, dimana jumlah dimensi dari citra jauh lebih besar dibandingkan dengan jumlah data sampel yang digunakan, untuk melakukan proyeksi sampel vektor dari citra pelatihan, setiap citra pelatihan disusun dalam bentuk vektor baris. Jika jumlah data pelatihan adalah sebanyak m, maka dimensi vektornya adalah mxn. Apabila vektor citra pelatihan mempunyai dimensi mxn tersebut diortogonalisasi dengan menentukan eigenvector dan eigenvalue, maka dimensinya akan berubah menjadi mxm, dimana m<<n.

Referensi :

Hasad A. 2010. Penerapan PCA pada Transformasi Wajah Menggunakan Matlab, Sekolah Pascasarjana IPB, Bogor.

Purnomo H. M., Muntasa A. 2010. Konsep Pengolahan Citra Digital dan Ekstraksi Fitur, Graha Ilmu, Yogyakarta.

Algoritma Optimasi Probabilistik dan Deterministik

ALGORITMA OPTIMASI PROBABILISTIK DAN DETERMINISTIK

A Hasad
Program Studi Teknik Elektronika
Fakultas Teknik, Universitas Islam 45 (UNISMA)
Jl. Cut Meutia No. 83 Bekasi 17113
Telp. +6221-88344436, Fax. +6221-8801192
Website: andihasad.com, Email: andihasad@yahoo.com

Dalam kehidupan sehari-hari, kita akan mudah menemukan permasalahan dari algoritma optimasi. Salah satu contohnya adalah bagaimana menyusun jadwal perkuliahan  sehingga tidak bentrok ruangan, dosen, maupun mahasiswa dengan distribusi yang adil dan semaksimal mungkin memenuhi kebutuhan semua pihak. Untuk menyelesaikan berbagai permasalahan seperti itu, para ahli telah mengelompokkan berbagai algoritma ke dalam kelompok Algoritma Optimasi (AO). Setiap algoritma memiliki kelebihan dan kekurangan masing-masing dalam menyelesaikan suatu masalah, karena tidak ada satupun algoritma yang berlaku umum dan bisa digunakan untuk menyelesaikan semua jenis masalah. Olehnya itu, diperlukan kemampuan memilih AO yang paling tepat (sesuai) untuk menyelesaikan masalah yang dihadapi.

Para ahli mengelompokkan AO ke dalam dua kelompok, seperti yang diperlihatkan pada Gambar 1, yaitu :

  1. AO  Deterministik
  2. AO  Probabilistik

Gambar 1  Pengelompokan Algoritma Optimasi

Perbedaan yang mendasar dari kedua kelompok tersebut adalah pada setiap langkah eksekusi di dalam AO Deterministik, hanya terdapat  satu jalan untuk diproses, jika tidak ada jalan maka algoritma dianggap selesai. Dengan demikian AO ini selalu menghasilkan solusi yang tetap untuk suatu input yang diberikan. Algoritma ini biasanya digunakan untuk masalah yang ruang solusinya tidak terlalu besar, sedangkan AO Probabalistik  digunakan untuk menyelesaikan  ruang masalah dengan ruang solusi yang sangat besar, bahkan tak terbatas. Algoritma Probabilistik berusaha menemukan solusi yang “bagus” tanpa melebihi batasan waktu yang telah ditentukan. Solusi yang “bagus” belum tentu yang paling optimal, namun sudah dapat diterima oleh user. Contohnya menyelesaikan masalah  TSP (Travelling Salesman Problem) untuk jutaan lokasi, maka akan memerlukan 1000 tahun komputasi jika diselesaikan dengan AO Deterministik . Jika kita menginginkan solusi dalam satu hari maka solusi menggunakan AO Deterministik tidak mungkin dilakukan. Namun jika ada AO Probabilistik yang bisa memberikan solusi yang “bagus” (sedikit lebih besar daripada solusi paling minimum, tetapi bisa diterima oleh kita) dalam waktu satu hari,  maka kita bisa menggunakan algoritma tersebut.

Selengkapnya mengenai Algoritma Optimasi dan Aplikasinya … download [pdf]

Referensi :

Hasad A. 2011. Algoritma Optimasi dan Aplikasinya, Sekolah Pascasarjana IPB, Bogor.

Suyanto. 2010. Algoritma Optimasi Deterministik atau Probabistik, Graha Ilmu, Yogyakarta.

Keuntungan dan Kerugian Penggunaan NAT

KEUNTUNGAN DAN KERUGIAN PENGGUNAAN NAT

DALAM ADMINISTRASI JARINGAN

Andi Hasad
Program Studi Teknik Elektronika
Fakultas Teknik, Universitas Islam 45 (UNISMA)
Jl. Cut Meutia No. 83 Bekasi 17113
Telp. +6221-88344436, Fax. +6221-8801192
Website: andihasad.com, Email: andihasad@yahoo.com

 Internet Protocol Address (alamat IP) merupakan suatu komponen vital dalam dunia internet, karena alamat IP dapat dikatakan sebagai identitas dari pemakai internet, sehingga antara satu alamat dengan alamat lainnya tidak boleh sama. Pada awal perkembangan internet digunakan IP versi 4 (IPv4) yang penggunaannya masih dirasakan sampai sekarang.

Sebelum terciptanya internet protokol, jaringan memiliki peralatan dan protokol tersendiri yang digunakan untuk saling berhubungan, sehingga mainframe vendor A tidak dapat berkomunikasi dengan mini computer pada vendor B, begitu pun sebaliknya. Dari permasalahan tersebut, kemudian dibuatlah suatu protokol yang dapat digunakan secara umum untuk menyatukan berbagai perbedaan dalam penggunaan perangkat yang terhubung didalam jaringan. Protokol tersebutlah yang sampai saat ini masih mendominasi dalam pemakaiannya oleh masyarakat banyak, yaitu internet protokol versi 4 atau disingkat IPv4.

 

Gambar 1  Contoh Pengalamatan IPv4

IPv4 yang kita kenal saat ini, dibagi dalam beberapa kelas. Alasan pembagian kelas tersebut adalah :

  • Memudahkan  sistem pengelolaan dan pengaturan alamat-alamat.
  • Memanfaatkan jumlah alamat yang ada secara optimum (tidak ada alamat yang terlewat).
  • Memudahkan pengorganisasian jaringan di seluruh dunia dengan membedakan jaringan tersebut termasuk kategori besar, menengah, atau kecil.
  • Membedakan antara alamat untuk jaringan dan alamat untuk host/router.

Gambar 2  Pembagian Kelas pada IPv4

              Network Address Translation atau NAT adalah suatu metode untuk menghubungkan lebih dari satu komputer ke jaringan internet dengan menggunakan satu alamat IP. Banyaknya penggunaan metode ini disebabkan karena ketersediaan alamat IP yang terbatas, kebutuhan akan keamanan (security), dan kemudahan serta fleksibilitas dalam administrasi jaringan. Saat ini, protokol IP yang banyak digunakan adalah IP versi 4 (IPv4, memiliki panjang alamat 4 byte berarti terdapat 2 pangkat 32 = 4.294.967.296 alamat IP yang tersedia. Jumlah ini secara teoretis adalah jumlah komputer yang dapat langsung koneksi ke internet.

Keterbatasan alamat pada IPv4 merupakan masalah pada jaringan global atau Internet. Untuk memaksimalkan penggunakan alamat IP yang diberikan oleh Internet Service Provider (ISP), maka dapat digunakan Network Address Translation atau sering disingkat dengan NAT. NAT membuat jaringan yang menggunakan alamat lokal (private), alamat yang tidak boleh ada dalam tabel routing Internet dan dikhususkan untuk jaringan lokal/intranet, agar dapat berkomunikasi ke Internet dengan jalan meminjam alamat IP internet yang dialokasikan oleh ISP.

Gambar 3 Network Address Translation (NAT)

Dengan teknologi NAT maka dimungkinkan alamat IP lokal/ private terhubung ke jaringan publik seperti internet. Sebuah router NAT ditempatkan antara jaringan lokal (inside network) dan jaringan publik (outside network), dan mentranslasikan alamat lokal/internal menjadi alamat IP global yang unik sebelum mengirimkan paket ke jaringan luar seperti Internet. Sehingga dengan NAT, jaringan internal/lokal tidak akan terlihat oleh dunia luar/internet.

NAT dapat dibagi menjadi 2 bagian , yaitu:

1. Statis

Translasi statis terjadi ketika sebuah alamat lokal (inside) di petakan kepada sebuah alamat global/internet (outside). Alamat lokal dan global tersebut dipetakan satu lawan satu secara statistik.

2. Dinamis

•   NAT dengan kelompok

Translasi Dinamis terjadi ketika router NAT diset untuk memahami alamat lokal yang harus ditranslasikan, dan kelompok (pool) alamat global yang akan digunakan untuk terhubung ke internet. Proses NAT Dinamis ini dapat memetakan beberapa kelompok alamat lokal ke beberapa kelompok alamat global.

•    NAT overload

Sejumlah IP lokal (internal) dapat ditranslasikan ke satu alamat IP global (outside). Hal ini sangat menghemat penggunakan alokasi IP dari ISP. STiarmg/pemakaian bersama satu alamat IP ini menggunakan metode port multiplexing, atau perubahan port ke paket outbound.

Keuntungan penggunaan NAT, antara lain :

  • Menghemat alamat IP legal yang ditetapkan oleh NIC atau service provider
  • Mengurangi terjadinya duplikat alamat jaringan
  • Meningkatkan fleksibilitas untuk koneksi ke internet
  • Menghindarkan proses pengalamatan kembali (readdressing) pada saat jaringan berubah
  • Meningkatkan keamanan sebuah jaringan.
  • Memberikan keluwesan dan performa dibandingkan aplikasi alternatif setingkat proxy.

Kerugian penggunaan NAT, antara lain :

  • Translasi menimbulkan delay switching
  • Menghilangkan kemampuan trace (traceability) end to end IP
  • Aplikasi tertentu tidak dapat berjalan jika menggunakan NAT, khususnya NAT yang menggunakan software

Selengkapnya…  Download [pdf Writing]

Referensi

Hasad Andi. 2010. Keuntungan dan Kerugian Penggunaan NAT dalam Administrasi Jaringan, Sekolah Pascasarjana IPB, Bogor.

Sugeng, Winarno, 2010, Jaringan Komputer TCP/IP, Modula, Bandung

Tanenbaum, S. Andrew. 2004, Computer Network, Fourth Edition, Prentice Hall, USA

Wahjuni, Sri, 2010, Materi Kuliah Analisis Jaringan Komputer, Sekolah Pascasarjana IPB, Bogor

Wendel Odom, 2004, CCNA ICND Exam Certification Guide, Cisco Press, Indianapolis, USA.

Verifikasi dan Validasi dalam Simulasi Model

VERIFIKASI DAN VALIDASI DALAM SIMULASI MODEL

Andi Hasad
Program Studi Teknik Elektronika
Fakultas Teknik, Universitas Islam 45 (UNISMA)
Jl. Cut Meutia No. 83 Bekasi 17113
Telp. +6221-88344436, Fax. +6221-8801192
Website: andihasad.com, Email: andihasad@yahoo.com

Verifikasi bertujuan untuk membuktikan bahwa sesuatu ada atau benar, atau untuk memastikan bahwa sesuatu adalah benar (Verify : to prove that something exists or is true, or to make certain that something is correct), sedangkan validasi bertujuan untuk membuat sesuatu yang resmi diterima atau disetujui, terutama setelah memeriksanya (Validate : to make something officially acceptable or approved, especially after examining it)  (Cambridge Dictionaries Online, 2011).

Menurut Sargent (1999) verifikasi model yang terkomputerisasi (computerized) memastikan bahwa pemrograman komputer dan implementasi model konseptual adalah benar. Untuk membantu memastikan bahwa sebuah program komputer adalah benar, desain program dan prosedur pengembangan pada bidang software engineering sebaiknya digunakan dalam pengembangan  dan implementasi program komputer. Hal ini termasuk desain object oriented, desain top-down, pemrograman terstruktur dan modularity program. Sedangkan validasi model terkomputerisasi (computerized)  berarti memastikan  bahwa program komputer dari model yang terkomputerisasi beserta implementasinya adalah valid (sah dan diterima ) atau tidak valid.

Gambar 1  Proses Pemodelan Sistem (Sargent, 1999)

Dalam proses validasi, terdapat 3 pendekatan utama yang digunakan untuk menentukan kapan sebuah model simulasi adalah valid atau tidak valid. Setiap pendekatan membutuhkan tim pengembangan model untuk melakukan verifikasi dan validasi sebagai bagian dari proses pengembangan model. Pendekatan umum yang paling banyak untuk tim pengembangan adalah membuat keputusan bahwa model tersebut valid. Ini adalah keputusan subyektif yang berdasarkan pada berbagai pengujian dan evaluasi yang dilakukan sebagai bagian dari proses pengembangan model.

Tabel 1 Evaluasi Untuk Validitas Model Konseptual

Tabel evaluasi untuk validitas model konseptual

Pendekatan yang lain, sering disebut verifikasi dan validasi independen, digunakan oleh pihak ketiga (independen) untuk menentukan kapan model itu valid. Pihak ketiga adalah independen dari kedua sisi, baik dari sisi tim pengembangan model maupun sponsor/pengguna model. Setelah sebuah model dikembangkan, pihak ketiga melakukan evaluasi untuk menentukan validitasnya. Berdasarkan validasi ini, pihak ketiga membuat sebuah keputusan subyektif pada validitas dari model tersebut.

Pendekatan terakhir untuk menentukan kapan sebuah model adalah valid untuk digunakan adalah model penentuan nilai (scoring). Skor atau bobot ditentukan secara subyektif ketika melakukan proses validasi dari berbagai aspek dan kemudian dikombinasikan untuk menentukan nilai (skor) kategori dan skor keseluruhan untuk model simulasi. Sebuah model simulasi dinyatakan valid jika skor kategori dan skor keseluruhan  lebih besar dari beberapa skor lainnya. Pendekatan ini tidak sering digunakan dalam praktek.

Gambar 2  Simulasi Komputer

Menurut Hoover dan Perry  (1989) verifikasi adalah pemeriksaan apakah program komputer simulasi berjalan sesuai dengan yang diinginkan, dengan pemeriksaan program komputer. Verifikasi memeriksa penerjemahan model simulasi konseptual (diagram alur dan asumsi) ke dalam bahasa pemrograman secara benar (Law dan Kelton, 1991), sedangkan validasi adalah proses penentuan apakah model, sebagai konseptualisasi atau abstraksi, merupakan representasi berarti dan akurat dari sistem nyata ? (Hoover dan Perry, 1989). Validasi adalah penentuan apakah model konseptual simulasi (sebagai tandingan program komputer) adalah representasi akurat dari sistem nyata yang sedang dimodelkan (Law dan Kelton, 1991).

Sargent (1999) menyimpulkan dalam papernya yang berjudul “Verification and Validation of Simulation Models” bahwa verifikasi dan validasi model adalah hal yang sangat penting dalam pengembangan sebuah model simulasi. Namun disayangkan, tidak ada pengujian khusus yang dapat dengan mudah diaplikasikan untuk menentukan “kebenaran” dari sebuah model. Lebih jauh, belum ada algoritma yang dapat menentukan teknik atau prosedur apa yang dapat digunakan. Setiap proyek simulasi menghadirkan sebuah tantangan yang unik dan baru.

Selengkapnya … Baca ringkasan disini  [Download pdf Writing] [Download pdf Sargent]

Referensi

Cambridge University Press. 2011. Cambridge Dictionaries Online. http://dictionary.cambridge.org/, diakses pada 1 Oktober 2011.

Hoover, Perry. 1989. Simulation A Problem-Solving Approach. Addison-Wesley., USA.

Law, Kelton. 1991. Simulation Modeling and Analysis. McGraw-Hill Inc., 2nd Edition, New York, USA.

Sargent RG. 1998. Verification and Validation of Simulation Models. Proceeding of The 1998 Winter Simulation Conference. USA. hlm 121-130.

Dioda Daya dan Aplikasinya

Dioda Daya dan Aplikasinya

Andi Hasad
Program Studi Teknik Elektronika
Fakultas Teknik, Universitas Islam 45 (UNISMA)
Jl. Cut Meutia No. 83 Bekasi 17113
Telp. +6221-88344436, Fax. +6221-8801192
Website: andihasad.com, Email: andihasad@yahoo.com

Perbedaan dioda daya dibandingkan dioda sinyal pn-junction  :

  • Memiliki daya yang besar
  • Kemampuan menangani tegangan dan arus  yang lebih besar
  • Respon frekuensi (kecepatan pensaklaran) lebih rendah dibanding dioda sinyal

Gambar 1  Dioda daya dan dioda sinyal pn junction

Tipe Dioda Daya

  1. Dioda Umum atau Serbaguna
  2. Dioda Schottky
  3. Dioda Pemulihan Cepat

Gambar 2 Dioda Daya

1. Dioda Umum / Serbaguna

  • Waktu pemulihan mundur relatif tinggi, biasanya 25 us
  • Digunakan untuk aplikasi kecepatan rendah (waktu pemulihan tidak kritis)
  • Arus 1 – ribuan Ampere, tegangan 50 V – 5 kV
  • Secara umum dibuat dengan difusi
  • Tipe campuran (alloy) dari penyearah yang digunakan  untuk suplay daya pengelasan
  1. Paling efektif pembiayaannya
  2. Kasar
  3. Memiliki tingkat kemampuan 300 V – 1000 V

2. Dioda Schottky

  • Masalah pengisian penyimpan pn junction dapat diminimalkan bahkan dihilangkan dalam dioda ini
  • Pengisian pemulihan jauh lebih kecil daripada dioda pn junction yang ekuivalen.
  • Dioda schottky memiliki tegangan jatuh yang relatif kecil
  • Arus bocor lebih tinggi daripada dioda pn junction , olehnya itu tegangan maksimum yang diizinkan dibatas 100 V
  • Tingkat arus bervariasi 1 – 300 A
  • Ideal digunakan untuk arus tinggi, tegangan rendah catu daya dc. Meskipun demikian dioda ini juga diterapkan pada catu daya arus kecil untuk meningkatkan efisiensi.

3. Dioda Pemulihan Cepat

  • Waktu pemulihan rendah  kurang dari 5 us
  • Digunakan untuk konverter dc-dc dan dc-ac
  • Arus 1 – ratusan Ampere, tegangan 50 V– 3 kV
  • Untuk tingkat tegangan di atas 400 V, dibuat dengan difusi dan waktu pemulihan mundur diatur oleh  difusi platina / emas
  • Untuk tingkat tegangan di bawah 400 V, dioda epiktasi lebih cepat dibanding dioda difusi
  • Dioda pemulihan cepat memiliki lebar basis yang tipis, yang menghasilkan waktu pemulihan ulang kurang dari 50 ns

Aplikasi  Dioda  Daya

Aplikasi dioda daya selain sebagai saklar dalam penyearah :

  • Freewheeling dalam regulator saklar
  • Pengisian balik kapasitor dan transfer energi antar komponen
  • Isolasi tegangan
  • Balikan energi dari beban ke sumber daya

Selengkapnya … Download [ pdf slides ] [ pdf  Writing ]

Referensi

Hasad A. 2011. Materi Kuliah Elektronika Industri. Teknik Elektro, UNISMA, Bekasi

http://elektroindonesia.com,  diakses tanggal 15 Oktober 2011

http://www.electronics-tutorials.ws, diakses tanggal 15 Oktober 2011

Petruzella F.D., 2001, Elektronik Industri, Andi Yogyakarta

Rashid M.H., 1999, Elektronika Daya, PT. Prenhallindo, Jakarta

Rockis G., Solid State Fundamentals for Electricians,  Energy Concepts Inc.

 

Menjaga password dan Keamanan Komputer dari Cracker

MENJAGA PASSWORD DAN KEAMANAN KOMPUTER DARI CRACKER

Andi Hasad
Program Studi Teknik Elektronika
Fakultas Teknik, Universitas Islam 45 (UNISMA)
Jl. Cut Meutia No. 83 Bekasi 17113
Telp. +6221-88344436, Fax. +6221-8801192
Website: andihasad.com, Email: andihasad@yahoo.com

I.  Menjaga Password

Password  adalah kumpulan karakter atau string yang digunakan oleh pengguna (user) baik itu user jejaring sosial,user email, user jaringan  ataupun  sistem operasi untuk memverifikasi identitas dirinya kepada sistem keamanan yang dimiliki oleh jaringan atau sistem tersebut.  Sistem keamanan akan membandingkan kode-kode yang dimasukkan oleh pengguna (yang terdiri atas nama pengguna/user name dan password) dengan daftar atau basis data yang disimpan oleh sistem keamanan sistem atau jaringan tersebut (dengan menggunakan metode autentikasi tertentu, seperti halnya kriptografi, hash atau lainnya). Jika kode yang dibandingkan cocok, maka sistem keamanan akan mengizinkan akses kepada pengguna tersebut terhadap layanan dan sumber daya yang terdapat di dalam jaringan atau sistem tersebut, sesuai dengan level keamanan yang dimiliki oleh pengguna tersebut. Idealnya, kata kunci merupakan gabungan dari karakter teks alfabet (A-Z, a-z), angka (0-9), tanda baca (!?,.=-) atau karakter lainnya yang tidak dapat (atau susah) ditebak oleh para intruder sistem atau jaringan. Meskipun begitu, banyak pengguna yang menggunakan kata sandi yang berupa kata-kata yang mudah diingat, seperti halnya yang terdapat dalam kamus, ensiklopedia (seperti nama tokoh, dan lainnya), atau yang mudah ditebak oleh intruder sistem.

Baru-baru ini salah  seorang teman mengeluh karena password facebooknya telah dihack oleh orang  yang tidak bertanggung jawab. Tentunya banyak hal negatif yang dapat terjadi ketika password anda bocor ke tangan orang lain.  Untuk mencegah hal tersebut terjadi, berikut beberapa tips /  kiat singkat untuk menjaganya.

1. Tidak Menggunakan Default Password
Default password adalah password yang kita dapat pertama kali. Password standar ini sebaiknya memang harus cepat diganti lantaran sangat rentan. Pasalnya, default password dapat dicari dengan mudah di google search, bahkan di situ tercantum nama mesin, type dan default password terpampang dengan megah di beberapa situs vendor pembuatnya.

2.Tidak Memakai Password Hint
Terkadang kita takut lupa dengan password yang sudah kita entry ke dalam sistem/account, sehingga kita perlu membuat sebuah pengingat bila kita lupa dengan password tersebut. Nah pengingat ini disebut password Hint, bila kita membuat pertanyaan dengan password hint ini maka dengan cepat kita dapat mengingat kembali password yang lupa tersebut. Begitu juga dengan para hacker, mereka akan mencoba-coba dengan menebak password kita dengan berbagai pertanyaan di password hint, lama kelamaan password tersebut akan tertebak, bila pertanyaan yang tertera di password hint dapat dijawab oleh si penebak password.

3.Tidak Menuliskan Password
Pemilik password sering kali takut lupa dengan password yang telah dimasukkan, sehingga pemilik password akan menuliskan berbagai user id dan passwordnya ke dalam media lain seperti notebook, notepad, stickies (mac), password folder, buku, handphone dan lainnya.

Hal ini juga cukup rentan bocor. Mengapa rentan? Karena bila berbagai peralatan tersebut hilang, maka semua informasi tentang user id dan password tersebut cepat atau lambat akan diketahui oleh si pencuri peralatan/gadget yang hilang.

4.Menggunakan Password yang Kuat

Pemilik password seringkali menggunakan password yang pendek saja, kalau saja bisa lebih pendek dari 3 character maka user tersebut akan memberikan password yang pendek. Untung saja saat ini sistem memberikan panjang password minimal 6 karakter dan maksimal 254 karakter. Semakin panjang sebuah password maka akan semakin kuat keamanan password tersebut.

Password yang kuat dapat dibuat dengan kombinasi angka dan huruf bahkan berbagai karakter yang lain. Beberapa admin saat ini menggunakan password yang cukup panjang, ditambah dengan enkripsi seperti PGP key dan lainnya, sehingga cukup sulit untuk dapat menebak password tersebut.

5.Sering Mengubah Password
Pemilik password sebaiknya secara berkala mengubah password untuk autentikasi tersebut, semakin sering password berubah semakin baik, karena semakin sulit si penebak password menjebol account/system kita. Perubahan terhadap password tergantung si pemilik, bisa seminggu, sebulan, tiga bulan sekali dan lainnya. Asal si pemilik tidak lupa dengan password yang sudah diubah tadi.

6.Tidak Memakai Password Sama pada Beberapa Account

Pemilik password kadang sering lupa dan sering membuat account yang cukup banyak, sehingga mereka setiap membuat account baru menggunakan user id yang sama dan password yang sama, ini sangat rentan dan bahaya. Karena satu account tembus password ini, maka semua account akan dapat diambil oleh Black hacker.

7. Menggunakan Manajemen Password
Untuk membantu mengingatkan kembali berbagai password dan berbagai account, seringkali kita sangat kesulitan, tapi tidak perlu khawatir karena sudah banyak saat ini aplikasi untuk membantu menata password kita. Aplikasi ini dapat didownload secara gratis dari internet maupun berbayar ( klik di sini untuk download manajemen password gratis ), sehingga berapapun account kita dan berapapun password kita dapat dengan mudah untuk diingat dan dibuka kembali, tentu saja untuk membukanya dengan metode enkripsi juga.

 

II.  Menjaga kemanan komputer dari Black cracker

Komputer kena hack bisa terjadi pada siapapun, walaupun anda sudah merasa jago komputer. Di atas langit masih ada langit, demikian kata pepatah. Di luar sana, masih banyak yang lebih “jago” dari kita. Sering kita lihat ada orang yang belagu (sombong) atau maborro kalau dalam bahasa daerah saya ketika dia merasa sudah tahu banyak. Padahal, sebenarnya semakin banyak kita belajar semakin sadar kita bahwa sedikit sekali yang kita ketahui. Jadi tidak ada salahnya jika anda menerapkan berbagai tips berikut untuk menjaga keamanan dan data anda dari para cracker  :

1. Hati-hati terhadap situs phising

Situs phising semakin  banyak beredar saat ini (contoh: www.swiiscash.net – harusnya http://www.swisscah.net dan www.e-qold.com – G-nya diganti pakai Q).  Situs tersebut memang disiapkan untuk menjebak sang korban, apalagi si korban gaptek (baca : gagap teknologi) di bidang internet security , hampir dipastikan akan terjebak pada situs ini. Sebaiknya anda jangan masuk ke situs ini walaupun hanya sekedar iseng dan tingkatkan ketelitian ketika mengetik alamat situs yang sebenarnya.

2. Tidak masuk ke situs apapun lewat e-mail klik / e-mail link

Email click dan email link yang masuk bisa membawa masalah karena bisa berpotensi dimana klik digunakan utk mendownload active-x yg bisa meng-hijack (membajak) browser anda kecuali anda yakin bahwa link tersebut aman atau untuk mengaktifkan registrasi. Hampir 90% orang di-hack karena hal ini atau efek lainnya  komputer korban bisa terkena spyware / virus

3.  Memakai browser  yang sudah terbukti memiliki  sekuriti  yang baik

Browser yang benar-benar aman memang  mustahil dalam dunia teknis, tetap saja ada celah untuk dimanfaatkan baik itu  Mozilla Firefox, Internet Explorer, Google Chrome, opera dan lainnya. Membekali komputer dengan tool tambahan bisa menjadi solusi yang lebih baik , misalnya kalau anda penggemar Internet Explorer ,  anda dapat menutup celah keamanan IE dengan memasang EMET (Enhanced Mitigation Experience Toolkit),  download  EMET klik di sini

4. Memasang Firewall pada komputer

Menggunakan firewall menjadi penting pada saat ini, apalagi jika anda sering terhubung ke  internet, maka langkah pengamanan menjadi prioritas utama agar kelak anda tidak pusing karena tiba-tiba kehilangan data penting di komputer. Salah satu firewall gratis adalah  ZoneAlarm yang bisa di-download di www.zonelabs.com

5. Sering update Windows

Jika anda menggunakan windows asli, jangan sia-siakan kesempatan update  dengan patch terbaru secara berkala  dari situs resminya.

6. Install antivirus dan antispyware

Anti virus salah satu software prioritas yang harus anda install, walaupun anda menggunakan tool refresh ,  misalnya deep freeze, tidak ada salahnya anda melengkapi komputer anda dengan anti virus / anti spyware, misalnya Smadav, paling tidak untuk scan flashdisk atau hardisk eksternal

7. Tidak melakukan internet banking atau membuka account investasi atau account penting lain anda di warnet (tempat publik)

Melakukan internet banking atau membuka account  penting di  warnet (warung internet) yang tidak memiliki firewall atau  anda tidak yakin bahwa komputer di warnet tersebut aman, bisa menjadi bencana yang besar buat anda. Saat ini, banyak cara yang digunakan  untuk mencuri account password maupun data penting lainnya. Account anda bisa terkena hack karena keylogger (program pencatat aktifitas keyboard dan situs yang anda buka), bahkan ada yang menggunakan keyboard yang mampu merekam apa saja yang anda ketik (kalau yang ini tidak perlu software khusus, karena hardware keyboardnya memang dirancang khusus untuk itu). Jadi sebaiknya anda cek startup Windows-nya dahulu dan matikan akses yang anda anggap berbahaya. Namun tetap  cara yang  paling aman, adalah mengakses account penting atau internet banking anda  dari gadget / komputer pribadi.

8. Tidak  membuka / mendownload attachment file di e-mail yang tidak dikenal

Maraknya spam dan program jahat lainnya menjadikan kita harus lebih waspada khususnya ketika membuka attachment (sisipan) email, apalagi kalau anda  tidak tahu e-mail itu dari siapa, ditambah lagi  e-mail berasal dari luar negeri yang umumnya berbahasa Inggris. Segera ambil tindakan dengan menghapus dari inbox anda, sehingga menutup kemungkinan jika suatu saat  terlintas pikiran untuk iseng-iseng membukanya.

9. Tidak menginstall program gratisan secara sembarangan

Berbayar belum tentu aman apalagi yang gratisan.  Sebaiknya anda meneliti terlebih dahulu situs resminya, khususnya situs-situs yang tidak terpercaya sebelum menginstall program yang sudah anda download. Menggunakan program P2P seperti Limewire, iMesh atau BearShare juga kurang bijak karena karena kadang-kadang program tersebut mengandung virus atau spyware.

Semoga berbagai tips di atas bermanfaat.

Dari berbagai sumber diantaranya : detik.com